Reported Site Performance
Incident Report for TrueLearn
Resolved
We have taken actions to stabilize performance. Application is responding appropriately.
Posted Jan 24, 2023 - 19:46 EST
Monitoring
We have restored service, but will continue to monitor performance during heavy usage.
Posted Jan 24, 2023 - 14:23 EST
Investigating
We're currently experiencing site performance issues. We are investigating and will report updates here as we get them.
Posted Jan 24, 2023 - 14:06 EST
This incident affected: Member/Learner Portal and Faculty/Admin Portal.