Site Performance
Incident Report for TrueLearn
Resolved
Site performance has been restored. We'll continue to monitor.
Posted Jan 21, 2023 - 17:23 EST
Investigating
We are currently experiencing longer than expected load times. Application performance may be impacted during use. We are investigating.
Posted Jan 21, 2023 - 16:44 EST
This incident affected: Member/Learner Portal and Faculty/Admin Portal.