Site Performance Issue

Incident Report for TrueLearn

Resolved

This incident has been resolved.
Posted Dec 20, 2024 - 11:26 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 20, 2024 - 11:12 EST

Investigating

We're currently seeing reduced performance on our site, causing slower page loading times and potential delays when navigating. Our team is investigating the cause and working to restore normal performance as soon as possible.
Posted Dec 20, 2024 - 11:02 EST
This incident affected: Member/Learner Portal, Faculty Portal, and Mobile App.