Degraded Performance

Incident Report for TrueLearn

Resolved

This incident has been resolved.
Posted Aug 31, 2024 - 00:05 EDT

Monitoring

Site performance has restored, continuing to monitor.
Posted Aug 31, 2024 - 00:02 EDT

Investigating

We are currently experiencing degraded performance and are investigating.
Posted Aug 30, 2024 - 23:34 EDT
This incident affected: Member/Learner Portal and Faculty Portal.