Intermittent Site Issues

Incident Report for TrueLearn

Resolved

This incident has been resolved.
Posted Jan 22, 2023 - 17:23 EST

Monitoring

Site stability has improved, we are continuing to monitor closely.
Posted Jan 22, 2023 - 16:27 EST

Investigating

We are currently investigating the issues with www.truelearn.net.
Posted Jan 22, 2023 - 15:52 EST
This incident affected: Member/Learner Portal.