Reported Site Performance
Incident Report for TrueLearn
Resolved
System performance has been restored. We will continue to monitor, ensuring optimal performance.
Posted Jan 19, 2023 - 22:31 EST
Investigating
We are currently experiencing longer than expected load times. Application performance may be impacted during use. We are investigating root cause and will provide status updates as we make progress.
Posted Jan 19, 2023 - 20:55 EST
This incident affected: Member/Learner Portal and Faculty/Admin Portal.