Reported Site Performance
Incident Report for TrueLearn
Resolved
This issue has been resolved.
Posted Jan 10, 2023 - 07:11 EST
Identified
We have identified an issue causing slowness in the application. This is due to a 3rd party integration that is currently down. We will continue to monitor the situation and provide updates as soon as stability is restored.
Posted Jan 09, 2023 - 13:15 EST
This incident affected: Member/Learner Portal.