Reported Site Performance
Incident Report for TrueLearn
Resolved
We have identified the issue and improved the site performance. The application is performing as expected now.
Posted Jan 24, 2023 - 13:21 EST
Investigating
We are currently experiencing slowness with our application. We are investigating the issue and will post updates as progress is made.
Posted Jan 24, 2023 - 12:24 EST
This incident affected: Member/Learner Portal and Faculty/Admin Portal.